Unable to do anything under edit details

Incident Report for PCS Australia

Resolved

This issue has all been resolved
Posted Jan 31, 2025 - 08:29 AEDT

Identified

We have identified the issue and a Fix will be rolled out later tonight
Posted Jan 30, 2025 - 21:41 AEDT

Update

This is currently being investigated by the Bug team and a fix will be worked on to resolve ASAP
Posted Jan 30, 2025 - 19:46 AEDT

Update

There is a work around for this issue, before clicking into the residents profile follow the steps below
1: Head into any community the resident is in
2: Head to the top right and run your mouse over your name
3: click 'Switch to New Monitor' (If you have 'switch to MCM' you are already in New Monitor and can skip this step)
4: Click residents profile and click edit details
5: Do action needed within Edit Details Before clicking Save
Posted Jan 30, 2025 - 13:30 AEDT

Investigating

We are currently investigating this issue and will hopefully have it resolved very soon
Posted Jan 30, 2025 - 13:28 AEDT
This incident affected: mCare (Monitor).